电工学习网

 找回密码
 立即注册
查看: 111|回复: 0

西门子840DSL数控机床更换伺服电机

[复制链接]
发表于 7 天前 | 显示全部楼层 |阅读模式
大年初二晚上,一个朋友打来电话,说一台840DSL的机床有个报警,让我帮忙看看,然后发来个报警图片:
6374954160509144658361975.jpg
看这几个报警感觉就是编码器回路有问题:1、可能是编码器或者编码器接口问题,2、编码器电缆,3、 电机模块编码器接口。
    建议他先换个电机试试,朋友回复说没有电机,那就只能先换编码器电缆或者电机模块试试了。
    第二天早上又给我打来电话,说是更换了编码器电缆和电机模块,还是一样的报警,现在找到一个电机,但与原来的电机差了一位。
1、 原电机 1FT7086-1AF71-1CH1
2、找到的电机1FT7086-1AF71-1FH1
我看了下是倒数第三位不一样,这一位是编码器的类型。我记得在论坛看过类似的问题,更换不同型号的电机,是需要重新拓扑识别的,而拓扑识别后,原来的驱动参数就会丢失,和他说了一下这种情况,他没处理过,让我过去帮忙处理下。
    反正家里待着也没事去看看吧,到了现场,看到它的系统是840DSL的,operate 版本4.7。报警就是上面那个,电机还没有更换,我找到驱动参数,拍了一张P1460和P1462参数的图片,想着更换完电机参数变了,最起码把这个增益和积分时间改成原来一样。
    然后做了NC和驱动的备份,又单独做了Z轴的驱动和轴的参数备份,然后断电,更换电机。换完后重新上电,弹出需要更新固件,应该是电机的固件版本与系统的不一样,那就更新吧,更新完毕提示重新上电,这个过程都没问题,我以为重新上电后会出现找到新的组件之类的报警,结果重新上电后没有任何报警,感觉这机床有问题啊,不按正常套路来呢,怎么没检测出电机型号不一样呢?
    在诊断里看了下轴的状态,发现一个问题,电机的测量系统1和2的状态里都写着“闲置”,查了下轴的DBX1.5=1,DBX1.6=0,这里没问题,我就奇怪了,还需要什么条件才能激活测量系统1?
    在驱动里看了下:
6374954163627896834755685.jpg
电机型号已经自动变成更换的电机型号1FH1了。
    查了下驱动的状态,代码好像是31,是等待使能,这里也是正常的。
    我就弄不清了还有什么条件会导致测量系统“闲置”?
    也没有报警可以参考,我决定就按照更换新电机的过程,重新做一下配置,再次进入驱动里,点击更改,进行电机配置,从上面的图可以看到,电机都自动识别出来了,所以只是一路点击下一步,没做任何更改,点击到编码器的步骤,我看菜单上有个识别,就点了下,然后一个峰回路转的对话框出现了,欲知后事如何,且听下回分说!
6374954166957581722994506.jpg
    从这个识别出的类型可以看到,上一个图的编码器AM24还是以前电机的,当前识别出的这个,是新更换电机的编码器。然后没在做其他更改,一路下一步结束配置。
    NCK复位后,在到诊断界面查看轴状态,测量系统1激活了,试了下手动移动,很正常,查看了下P1460及P1462参数,发现还是以前的参数,并没有改变。
    我感觉这里是因为电机没有变!在选择电机类型的时候,西门子电机的列表是类似这样的: 1FT7086-XAF7X-XXXX,其中的X可以是不同的,但他代表一个型号的电机,也就是这样的电机它的电机固有参数是一样的。而我更换的电机只是编码器类型不同,但电机其实是一样的,所以驱动由于电机没有变,所以参数也没有变,个人观点,也不知道理解的对不对!
然后试验了下自动加工,没什么问题,可以回家继续过年了。
来源:西门子工业技术论坛

回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

|电工学习网 ( )

GMT+8, 2021-3-1 20:33

Powered by © 2011-2021 www.diangon.com 版权所有 免责声明 不良信息举报

技术驱动未来! 电工学习网—专业电工基础知识电工技术学习网站。

栏目导航: 工控家园 | 三菱plc | 西门子plc | 欧姆龙plc | plc视频教程

快速回复 返回顶部 返回列表